Jevents 2.x (Free Access)

Frontend editing not saving new events. No errors

Discuss JEvents 2.x for Joomla 1.5-2.5 here - club members can use the special club forum for faster response times.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby wpee » Mon Mar 04, 2013 11:24 am

O, now you have to talk me through, where can I find these settings? I've never used, installed of changed settings for jquery

Wim
wpee
 
Posts: 11
Joined: Sun Mar 03, 2013 9:08 am

Postby Tonyp » Mon Mar 04, 2013 1:19 pm

Hello Wim,

Geraint is suggestion you look into your Sites Template configuration and if it allows turning off JQuery.

Otherwise, ask the guys at JQuery easy how they suggest disabling it with their plugin.

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23793
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby wpee » Mon Mar 04, 2013 1:29 pm

OKay, I'll check this.
The site's template is made using Artisteer, so I have to check and verify.
I already read in another thread that switching to BEEZ template eliminated the problem. Okay for a test I should say, I'll do that tonight and come back to this.

Wim

Wim
wpee
 
Posts: 11
Joined: Sun Mar 03, 2013 9:08 am

Postby wpee » Mon Mar 04, 2013 6:19 pm

I installed jQueryeasy
settings standard as the come during install:
frontend: enable jQuery:none
backend: enable jQuery:none



Also tried editing from frontend again, this time with firefox and errorconsole on.
I got the same error with additional info

Tijdstempel: 4-3-2013 19:12:58
Fout: ReferenceError: set12hTime is not defined
Bronbestand: http://www.mtkessel.nl/component/jevent ... =02&day=28
Regel: 2640


and after that

Tijdstempel: 4-3-2013 19:12:58
Fout: ReferenceError: toggleFreq is not defined
Bronbestand: http://www.mtkessel.nl/component/jevent ... =02&day=28
Regel: 2623

Sorry, in dutchtranslation of the browser.
Wim
wpee
 
Posts: 11
Joined: Sun Mar 03, 2013 9:08 am

Postby Tonyp » Mon Mar 04, 2013 10:58 pm

Hello,

Artister loads it's JQuery in no.conflict so thats ok.

You do not want to disable JQuery completely you want it to load in no.conflict mode?

I suspect there is a module/plugin causing the issue.

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23793
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby Geraint » Tue Mar 05, 2013 10:07 am

When you are in the event editing page - view the web page source in the browser and make sure the editical.js file is loaded. That is where set12Time is defined and so it toggleFreq
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42845
Joined: Fri Feb 15, 2008 6:14 pm

Postby wpee » Tue Mar 05, 2013 5:55 pm

I've used the error console, it is not loaded.
I checked the source, no editical.js is in it.
I've searched my webspace, it is in the directory administrator/components.com_jevents/assets/js, and this is the only place where it is. Should it not be located elsewhere .

The source shows also the jquery is loaded in noconflict.
<script type="text/javascript">jQuery.noConflict();</script>

gr Wim
wpee
 
Posts: 11
Joined: Sun Mar 03, 2013 9:08 am

Postby Geraint » Wed Mar 06, 2013 10:12 am

this file is loaded by the view.html.php file for event editing.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42845
Joined: Fri Feb 15, 2008 6:14 pm

Postby wpee » Wed Mar 06, 2013 8:33 pm

Hi Geraint.
I do not know how to check this exactly. I'm using firefox and IE, what debugging of developerwindow should I open to check.
The view.html.php file is on the server, but what should I check for?
What I did check is firefox with firebug,then I can not seen the editical.js loaded and not the view.html.php/
What I can see I PM you

gr Wim
wpee
 
Posts: 11
Joined: Sun Mar 03, 2013 9:08 am

Postby Geraint » Thu Mar 07, 2013 9:04 am

wpee wrote:Yes backend is flawlessly, no errors, alwaya been okay.
It's the front end. Error is the same when I login as administrator or any other user that is Author.

This is a problem with your template or a module/plugin you have installed - I'm guessing if you enable one of the core Joomla templates e.g. Beez_20 and disable the modules/plugins you have installed then there is no problem.

Something you have installed is interfering with normal Joomla behaviour/functionality and affecting JEvents. I'm afraid you'll have to isolate the specific cause - disable the modules/plugins and use Beez_20 and then enable the modules/plugins and template one at a time to find the cause and then follow up with the developers of the offending addon.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42845
Joined: Fri Feb 15, 2008 6:14 pm

PreviousNext

Return to Jevents 2.x (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there is 1 user online :: 1 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Google [Bot]