Jevents 2.x (Free Access)

Frontend editing not saving new events. No errors

Discuss JEvents 2.x for Joomla 1.5-2.5 here - club members can use the special club forum for faster response times.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby wpee » Sun Mar 03, 2013 9:12 am

I have the same issue here, I'm interested in the result.
How can I check is motools is running? I have Joomla 2.5.8 running.
Here is my setup

Joomla : 2.5.8
component_com_jevents : 2.1.16
module_mod_jevents_cal : 2.1.3
module_mod_jevents_latest : 2.1.5


gr Wim
wpee
 
Posts: 11
Joined: Sun Mar 03, 2013 9:08 am

Postby carcam » Sun Mar 03, 2013 9:47 am

Your JEvents version is really old and also your Joomla! install needs an update as the latest 2.5.9 fixes a security issue.
¿Sabías que tenemos soporte en español para los miembros del Club de JEvents? ¡ÚNETE AHORA!
User avatar
carcam
Team Staff
 
Posts: 7114
Joined: Wed Aug 06, 2008 7:50 pm
Location: Almería

Postby wpee » Mon Mar 04, 2013 6:58 am

Now I've upgraded I've got the same issue
Joomla : 2.5.8
component_com_jevents : 2.2.8
module_mod_jevents_cal : 2.2.8
module_mod_jevents_latest : 2.2.5

Some more info: when I do not log in to the backend the issue is there. Just after I've logged in as administrator to the backend end logout again, I can login as user (other name) and make changes! Teh buttons save, apply, escape are nicely shown in the banner of my edit popup window of jevents.
A day later without logging into the backend changes are not possible anymore. No buttons are shown and no Jevents banner is shown in top of the edit popup window. However the text fields save, apply, escape are shown and are clickable but the result is nada, Something happens but the edits are not saved.

Wim
wpee
 
Posts: 11
Joined: Sun Mar 03, 2013 9:08 am

Postby Geraint » Mon Mar 04, 2013 8:38 am

wpee wrote:the result is nada, Something happens but the edits are not saved.

this is not specific enough I'm afraid - what happens? What is 'nada'? How do you know the edits are not saved - i.e. are you looking in the frontend or backend/edit page or detail page?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

Postby wpee » Mon Mar 04, 2013 9:23 am

NADA ,is a way of speaking "nothing"
When I press Save or Apply, I can see that my webbrowser is loading a new page. The page is loaded again but I end up with the same Jevents window, with the original event properties. Eveything what I had edited is reset to original. this is for title, timesettings and event description, these are the fields I have tested.
In the editing window I cannot see any changes are saved after pressing Save or Apply, after reload of the page is is set back to original.
The edits are for sure not saved because when I look in the calendar (frontend webpage view) the event is as original (original time, original title, original description)

BTW: backend is no problem at all, working fine.

What can I do as test, shall I sent you screenshots of check some settings?
wpee
 
Posts: 11
Joined: Sun Mar 03, 2013 9:08 am

Postby Geraint » Mon Mar 04, 2013 9:31 am

I know nada = nothing ;) but is nothing = white page, nothing = no browser response etc.

Problems could be :
1. javascript error (check firefox or chrome error console)
2. wysiwyg editor problem - make sure you do NOT use RokPad or CodeWarrier they are not proper editors
3. Overlapping event checking - have you disabled this if not please do so.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

Postby wpee » Mon Mar 04, 2013 9:58 am

Hi
1) can you PM me your mail adres, I found some errors related to date-fields, I want to sent a WORD file with screencaps
2) I use JoomlaCK editor
3) Overlapping event checking is off

Wim
wpee
 
Posts: 11
Joined: Sun Mar 03, 2013 9:08 am

Postby Geraint » Mon Mar 04, 2013 10:31 am

I'm afraid we only provide site specific support for club members.

Are there any javascript error messages? can you save events in the backend?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

Postby wpee » Mon Mar 04, 2013 11:10 am

Yes backend is flawlessly, no errors, alwaya been okay.
It's the front end. Error is the same when I login as administrator or any other user that is Author.

In the frontend when loading the edit window (before I've edited anything in the event) the script error shows a highlighted line:
2640 set12hTime(document.adminForm,start_time); and the console shows:
Object expected 41.html?itemid...........etc

Then I do a change in the event.
Ans when I press save, again an error pops up showing next line:
2396 reset(YMD)
On the right screen again showing "object" expected

gr Wim
wpee
 
Posts: 11
Joined: Sun Mar 03, 2013 9:08 am

Postby Geraint » Mon Mar 04, 2013 11:14 am

Te most likely problem is a jQuery clash with your template or another module - you need to make sure if jQuery is loaded that it is set in no-conflict mode.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

PreviousNext

Return to Jevents 2.x (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there is 1 user online :: 1 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Bing [Bot]