JEvents 3.1 (Free Access)

Bug in 3.0.7stable

Forum for JEvents 3.1 for Joomla 3.x and 2.5.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby Tonyp » Tue Feb 12, 2013 12:11 pm

Hello,

I suspect the kickout was down to your Joomla! Session setting being low.

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23633
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby madss » Tue Feb 12, 2013 1:23 pm

Unfortunately I still am having trouble. I had an event with a long description which had been (mis)placed on Dec. 5th (instead of May 12th). Tried changing the dates="invalid corrected" and it stayed in December. Tried to delete and make a new entry, for the right date, copy/pasting the long description which I didn't want to re-type, every time I save it is saved to December 5th instead of May 12th. I tried both clicking the "+" in the month table and by using the link to create new Calendar event in the menu, same result.
Please please let me make an account for you guys so you can see it in action - I get the feeling you think I'm talking shit :-(

Mads
madss
 
Posts: 9
Joined: Sun Feb 10, 2013 8:17 pm

Postby Geraint » Tue Feb 12, 2013 1:31 pm

December 5th and May 12th are linked in that May is month 5 and December is Month 12.

There was an issue (prior to 3.0.7) where with some date input format options the month and day were getting switched by javascript. It sounds as though you may be seeing this problem.

Are you sure you are on 3.0.7?

If you upgraded did you clear you web browser cache?

Can you try a different date format format in your Jevents config (e.g.Y-M-D) and see if it works then. If you can isolate the specific cause (e.g. specific date formats only) it will help us identify the cause of any potential bugs easier.

thanks
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42781
Joined: Fri Feb 15, 2008 6:14 pm

Postby madss » Tue Feb 12, 2013 4:23 pm

Yes I'm sure I am using 3.0.7 stable - look here: http://www.husby-tanderup.dk/ny_side/in ... 13/02/12/-

I haven't been able to reproduce the problem in the last few hours, this isn't to say my confidence is restored but I'm holding my breath...

Thanks for participating,
madss
 
Posts: 9
Joined: Sun Feb 10, 2013 8:17 pm

Postby SteveJ » Tue Feb 12, 2013 11:13 pm

Since I was also getting this error msg, as you have suggested, I have upgraded to 3.0.7, cleared browser cache, Joomla cache, cleaned everything up but still getting error msg "invalid corrected" when adding events on any date 28 or greater.

Know you will get this resolved.

Thanks in anticipation for a great product.
SteveJ
 
Posts: 3
Joined: Tue Feb 12, 2013 11:06 pm

Postby Geraint » Wed Feb 13, 2013 8:13 am

Can you take a look in the file administrator/components/com_jevents/assets/js/editical.js and make sure that the method jeventsParseDate at lines 51-55 looks like this
Code: Select all
         // set month to January  to ensure we can set days to 31 first!!!
         date.set('month', 0);
         if (year != null) date.set('year', year);
         if ('d' in bits) date.set('date', bits.d);
         if ('m' in bits || bits.b || bits.B) date.set('month', bits.m-1);

And can you open the file in your web browser (e.g. http://www.husby-tanderup.dk/ny_side/ad ... ditical.js) - this way you can make sure that the latest version is available and its not loaded from the cache.

If this doesn't resolve your issue - can you tell us:
1. Which web browser (and version) you are using?
2. If your webhost uses a proxy (this is VERY important since your web host may be caching this file before you even get to load it in your browser)?
3. Which date format you are using?
4. Which date you are trying to set?

thanks
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42781
Joined: Fri Feb 15, 2008 6:14 pm

Postby madss » Wed Feb 13, 2013 11:22 am

// set month to January to ensure we can set days to 31 first!!!
date.set('month', 0);
if (year != null) date.set('year', year);
if ('d' in bits) date.set('date', bits.d);
if ('m' in bits || bits.b || bits.B) date.set('month', bits.m-1);

Hi Geraint,

I have copied the relevant code here above - looks like it matches your expectations?
1) I am using Firefox version 18.0.2 (but my mate is having problems on the same site too, and I don't know what he is using)
2) It is a big webhotel with very many active domains on it (one.com) - I can't imagine they are using proxy servers,
I WAS using d.m.Y, changed that to d/m/Y and got LESS problems, but still had trouble moving an event which had been saved to the wrong dates. In the end I deleted the event, and my mate was able to make a new one on the right date (I couldn't from this workstation, it kept saving 12/5/2013 to 5/12/2013) and I could then edit the event from here and add all the information in the Comments field (!)

Hope this is useful,
madss
 
Posts: 9
Joined: Sun Feb 10, 2013 8:17 pm

Postby Geraint » Wed Feb 13, 2013 2:00 pm

Are you changing the start date or the end date of the event?

Can you confirm there is no issue with Y-M-D format?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42781
Joined: Fri Feb 15, 2008 6:14 pm

Postby madss » Wed Feb 13, 2013 2:15 pm

Hi Geraint,

I was changing the start date - since the system was saving it to December rather than May. Each time I got the "Invalid Corrected" and it just went back to December (or whatever the opposite of what I was doing would be).

Now however I have just tried switching to Y/M/D and there was no problem. Then I switched to d.m.Y (which caused lots of problems initially) and that works perfectly now...

Unless the problems reappear I won't disturb you guys again, thanks for taking an interest, and I will go and vote now,
madss
 
Posts: 9
Joined: Sun Feb 10, 2013 8:17 pm

Postby SteveJ » Wed Feb 13, 2013 3:38 pm

Don't know if this will help.

I have been testing this with both existing and new events and all fail for date of 29, 30 and 31 of every month. Although all months work for the date of 29 in a leap year.

I have been testing in both IE8 and Chrome, Joomla 2.5.9, JEevent 3.0.7.
SteveJ
 
Posts: 3
Joined: Tue Feb 12, 2013 11:06 pm

PreviousNext

Return to JEvents 3.1 (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 2 users online :: 2 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Bing [Bot], Google [Bot]