JEvents 1.5 (No longer actively supported)

[LANG STRINGS etc.] Esthetic fixes

JEvents 2.0 was launched over 2 years ago and the latest stable version is version 2.2 which will run on Joomla 1.5 and Joomla 2.5. JEvents 1.5 is therefore no longer actively supported - you should upgrade to JEvents 2.2+ as soon as possible.
Forum rules
Please include as much detail in any test or bug reports for JEvents 1.5 as possible.

First of all, check if you are running the latest available version of Joomla! and JEvents. Posts for issues, where both systems are not updated, will be ignored.

We need the following at least:

* PHP version (e.g. 5.2.5). Note: Support for PHP4 is discontinued.
* Joomla! version
* JEvents version
* Web Server software (Apache or IIS with version number if possible)
* Server Operating system (e.g. Linux, Windows, Solaris, Darwin ...)
* Database version
* memory_limit from your phpinfo
* Web browser and version

Please enable error reporting and include any error messages in your posting. You do this via the Joomla Configuration - set "error reporting" to "maximum" on the Server tab.

Finally, please describe the steps required to recreate the problem and also please enable error reporting and give us any error messages generated.

Postby jc513 » Wed Jan 14, 2009 6:17 pm

Low, non-critical stuff...making you aware



Have a JEV_EVENT_ISDEFAULT variable on the Manage iCals screen.

Start Time in Event editing reads AM/AM instead of AM/PM.

In template "EXT" missing /components/com_jevents/layouts/ext/images/mini_arrowleft.gif and /components/com_jevents/layouts/ext/images/mini_arrowright.gif
jc513
 
Posts: 46
Joined: Sun Nov 16, 2008 4:20 pm

Postby Geraint » Sat Jan 17, 2009 11:26 am

These should now be fixed in SVN
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42800
Joined: Fri Feb 15, 2008 6:14 pm

Postby jc513 » Sat Jan 17, 2009 7:00 pm

Yes and No.

It does read AM/PM now and the arrow gifs are there for EXT template.

However, I am still have these issues...

Control Panel : JEV_ADMIN_DBSETUP
Manage iCAL : JEV_EVENT_ISDEFAULT
Manage Categories : JEV_DESCRIPTION

Missing /components/com_jevents/views/ext/assets/images/help.gif in EXT template

For the language string issue could this be the issue. When I run debug to see which language files it opens I see that there is a '/\' in the line right before 'language'.

administrator/components/com_jevents/\language\en-GB\en-GB.com_jevents.ini
/components/com_jevents/\language\en-GB\en-GB.com_jevents.ini

-------
Apache 2.2.8/PHP 5.2.5 (40mb, magic quotes on)
MySQL 5.0.67
Windows
J! 1.5.9
jc513
 
Posts: 46
Joined: Sun Nov 16, 2008 4:20 pm

Postby hifi » Sun Jan 18, 2009 8:36 am

For some reason when displayin all three mod_jevents_cal mini-calendars, last one's calendar part is little wider than on others. I can't see what could make this, because last one shows identical to 2 others when looking CSS/styles with Web developers/Chrome's inpection.
hifi
 
Posts: 87
Joined: Tue Oct 28, 2008 6:29 am

Postby Geraint » Sun Jan 18, 2009 12:14 pm

The system shouldn't be using the component language files at all (they are only there for installation) - is this an upgrade from alpha2? I'm not seeing these missing language strings

Geraint
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42800
Joined: Fri Feb 15, 2008 6:14 pm

Postby jc513 » Sun Jan 18, 2009 4:29 pm

I have had a little chance to investigate this more on my dev/test system.

On a fresh install, you place language files in the following locations:

    /administrator/language/en-GB
    /administrator/components/com_jevents/language
    /language/en-GB
    /components/com_jevents/language

When, I do an SVN update in accordance with your instructions only the following language locations are updated:

    /administrator/components/com_jevents/language
    /components/com_jevents/language

If I copy out these new language files in these 'component' directories and place them in their appropriate language directory (admin or site) then I no longer get the language string problem.


Note: I still had to copy JEV_DESCRIPTION string from the site language file to the admin language file for the Manage Categories : JEV_DESCRIPTION display issue to go away.
jc513
 
Posts: 46
Joined: Sun Nov 16, 2008 4:20 pm

Postby Geraint » Sun Jan 18, 2009 7:52 pm

Sorry - forgot to mention that about SVN.

Geraint
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42800
Joined: Fri Feb 15, 2008 6:14 pm


Return to JEvents 1.5 (No longer actively supported)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 2 users online :: 2 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Bing [Bot], Yahoo [Bot]