JEvents 3.1 (Free Access)

Only one event showing

Forum for JEvents 3.1 for Joomla 3.x and 2.5.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby Pjaq » Wed Nov 21, 2012 1:52 pm

Hi there
I have a couple of problems with my installation...
I am using Joomla 3 and JEvents3.0

First I loaded 4 events, but only one showed up on the monthly calendar. I tried deleting events, moving them around etc. but could only get the one event to appear. When I deleted the one that worked, I couldn't get any of the others to appear.

So I thought I would try uninstalling and re-installing Jevents, but it is now not appearing under my components in the Joomla backend. It is there, as I can point a menu item to it and it works, but I can't access the backend.

I got the following error message during my re-installation.

Warning

JFolder: :files: Path is not a folder. Path: /home/eventrou/public_html/administrator/components/com_jevents

JInstaller: :Install: Cannot find XML setup file

JFolder: :files: Path is not a folder. Path: /home/eventrou/public_html/components/com_jevents

JInstaller: :Install: Cannot find XML setup file

Any help would be much appreciated. Thanks
Pjaq
 
Posts: 3
Joined: Wed Nov 21, 2012 12:36 pm

Postby Geraint » Wed Nov 21, 2012 2:31 pm

How did you do your uninstall? You need to uninstall the package and not the component.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42849
Joined: Fri Feb 15, 2008 6:14 pm

Postby Pjaq » Wed Nov 21, 2012 6:39 pm

Hi Geraint

I went Extensions>Extension manager>Manage(on the left) then checked Jevents and hit uninstall
Pjaq
 
Posts: 3
Joined: Wed Nov 21, 2012 12:36 pm

Postby Geraint » Thu Nov 22, 2012 10:13 am

There is a 'type' column - you installed a type='package' so if you uninstall the type='component' instead this could cause problems.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42849
Joined: Fri Feb 15, 2008 6:14 pm

Postby Pjaq » Thu Nov 22, 2012 12:13 pm

Hi Gerain

Thanks for that, I got it working again.
I also managed to re- create part of my previous problem, I think. What I did was to create an event in the past, which worked, but the end date turned out to be the present. So I went back in and changed the end date to the same day as the event. The event then disappeared off the events manager. It is still there on the calendar view, displaying a 1 day event that was in the past.
I think what I did previously was to try to re-create the disappeared event in the event manager (possibly with the same name), which maybe confused something causing all but one event to disappear off the calendar view.
I realize trying to create events in the past may be stupid, but I was trying to set up a demo.
Pjaq
 
Posts: 3
Joined: Wed Nov 21, 2012 12:36 pm

Postby Geraint » Thu Nov 22, 2012 1:31 pm

You can create historic events in JEvents - just remember that they are filtered out in the backend by default. There is a 'show past events' drop down to control if they are displayed or not.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42849
Joined: Fri Feb 15, 2008 6:14 pm


Return to JEvents 3.1 (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users