Jevents 2.x (Free Access)

http 500 error  Topic is solved

Discuss JEvents 2.x for Joomla 1.5-2.5 here - club members can use the special club forum for faster response times.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby Elise » Mon Nov 26, 2012 4:27 pm

configuration sef jevents.JPG
configuration sef jevents.JPG (60.25 KiB) Viewed 446 times
Hello,
I use the native Joomla SEF and yes, the htaccess file is enabled.
On the attached picture, you can see how I configure the sef in JEvents.
Thanks
Regards
Elise
 
Posts: 10
Joined: Mon Nov 19, 2012 10:40 am

Postby Geraint » Tue Nov 27, 2012 8:54 am

Do you have any caching addons installed?

Have you looked in the web server's error logs for helpful messages?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42799
Joined: Fri Feb 15, 2008 6:14 pm

Postby Elise » Tue Nov 27, 2012 9:38 am

Hello,
Thank you for your interest in my problem.
Unfortunately, I can not answer your questions!
I do not know what are addons!
I do not know where I have to look for the second question!
Sorry for my ignorance ..
Elise
 
Posts: 10
Joined: Mon Nov 19, 2012 10:40 am

Postby Jadzia » Mon Dec 03, 2012 3:57 am

I am having the same issue, with SEO off the link to JEvents works, with SEO on I get the http 500 error. If I use the non SEO url with SEO enabled it still has the 500 error.

I am using Joomla 2.5.8 JEvents 2.2.8, no cache, default Joomla SEO and .htaccess is enabled.
Error reporting shows;

Notice: Undefined index: reverse_proxy in /home/narromin/public_html/plugins/system/admintools/admintools/badbehaviour/core.inc.php on line 97

Notice: Undefined index: eu_cookie in /home/narromin/public_html/plugins/system/admintools/admintools/badbehaviour/screener.inc.php on line 8

Notice: Undefined property: JSite::$registeredurlparams in /home/narromin/public_html/libraries/joomla/cache/cache.php on line 639

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 141972 bytes) in /home/narromin/public_html/libraries/joomla/cache/controller.php on line 224
Jadzia
 
Posts: 4
Joined: Tue Jun 15, 2010 11:57 pm

Postby Tonyp » Mon Dec 03, 2012 8:44 am

Hello,

1. Please make sure you are using the latest version of JEvents
2. You are running out of php memory, you need to increase this.

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23758
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Postby Elise » Mon Dec 03, 2012 4:11 pm

Hello,
After much research, I have not found the solution to my problem.
I have no addons installed caching.
So I decided to try to work around the problem by installing a component redirect 500 errors.
Then I locked the indexing robots JEvents pages but I'm not sure that it avoids the increase found in pages 500 error.
As a last resort, if these changes do not solve the problem, I am unfortunately forced to remove the component JEvents my site ... It would be a pity, because this component is very good!
Thank you very much for the help you have given me.
good luck
Best regards
Elise
 
Posts: 10
Joined: Mon Nov 19, 2012 10:40 am

Postby Geraint » Mon Dec 03, 2012 4:24 pm

Jadzia wrote:Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 141972 bytes) in /home/narromin/public_html/libraries/joomla/cache/controller.php on line 224

This looks like it could be your problem - did you increase your memory settings?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42799
Joined: Fri Feb 15, 2008 6:14 pm

Postby Jadzia » Mon Dec 03, 2012 10:20 pm

I can do that but it was already set at 32mb which I would have thought more than sufficient for any script. I'm concerned that JEvents requires so much memory to run. Plus it looked like it tried to allocate 1and a half mb which is no where near the limit.
Jadzia
 
Posts: 4
Joined: Tue Jun 15, 2010 11:57 pm

Postby Tonyp » Tue Dec 04, 2012 12:36 am

Hello Jadzia,

Your memory limit is 32MB.

It was at just under 32MB and JEvents tried to allocate 0.13539505MB, however it was not there to allocate therefore failed.

32MB should be enough, but if you have a lot of event it won't be.

You should also try debugging your system with the Joomla! debug mode and profile the memory usage to see what is using memory.

Regards
Tony
---------------------------------------
Feel free to PM me if you would like Custom Installs or Joomla! related work for a competitive quote.

User avatar
Tonyp
Team Staff
 
Posts: 23758
Joined: Tue Oct 12, 2010 9:12 pm
Location: Isle of Man

Previous

Return to Jevents 2.x (Free Access)

cron
  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users