Jevents 2.x (Free Access)

J171 upgrade

Discuss JEvents 2.x for Joomla 1.5-2.5 here - club members can use the special club forum for faster response times.
Forum rules
When requesting support please follow these steps:

1. Update all JEvents add on's first, via the Joomla! Updater
2. Copy and Paste the JEvents Support Information from the JEvents Control Panel.
3. If you get a 500 error OR white page, enable Maximum Error Reporting in Joomla! Global Config and visit the page again, this should give you a more detailed error and help us provide a prompt response.

Postby Duke3D » Wed Sep 28, 2011 3:47 pm

I had a prefectly working Latest Events module, then applied the One-Click upgrade from J1.7.0 to J1.7.1 and then the dates stopped appearing in the module. The rendered HTML looks like:

Code: Select all
<table class="mod_events_latest_table" width="100%" cellspacing="0" cellpadding="0" border="0" align="center">
<tbody>
<tr>
<td class="mod_events_latest_first">
<span class="mod_events_latest_date"></span>
-
<span class="mod_events_latest_date">11:00AM</span>
<br>
<span class="mod_events_latest_content">
<a href="/coming-events/icalrepeat.detail/2011/09/24/2/13|14|15|16/ground-breaking-for-the-park">Ground Breaking for the Park</a>
</span>
</td>
</tr>
<tr>
<td class="mod_events_latest">
<span class="mod_events_latest_date"></span>
-
<span class="mod_events_latest_date"></span>
<br>
<span class="mod_events_latest_content">
<a href="/coming-events/icalrepeat.detail/2011/09/24/1/13|14|15|16/fall-equinox-pot-luck">Fall Equinox Pot Luck</a>
</span>
</td>
</tr>
<tr>
<td class="mod_events_latest">
<span class="mod_events_latest_date"></span>
-
<span class="mod_events_latest_date"></span>
<br>
<span class="mod_events_latest_content">
<a href="/coming-events/icalrepeat.detail/2011/10/01/3/13|14|15|16/yarden-prep-for-winter">Yarden Prep for Winter</a>
</span>
</td>
</tr>
</tbody>
</table>

Note the spans with no starting date and time.

Just prior to the upgrade it looked like:
(spans have starting dates.)
Code: Select all
<table class="mod_events_latest_table" width="100%" cellspacing="0" cellpadding="0" border="0" align="center">
<tbody>
<tr>
<td class="mod_events_latest_first">
<span class="mod_events_latest_date">Sat Sep 24 @10:00AM</span>
-
<span class="mod_events_latest_date">11:00AM</span>
<br>
<span class="mod_events_latest_content">
<a href="/coming-events/icalrepeat.detail/2011/09/24/2/13|14|15|16/ground-breaking-for-the-park">Ground Breaking for the Park</a>
</span>
</td>
</tr>
<tr>
<td class="mod_events_latest">
<span class="mod_events_latest_date">Sat Sep 24 @ 5:30PM</span>
-
<span class="mod_events_latest_date"></span>
<br>
<span class="mod_events_latest_content">
<a href="/coming-events/icalrepeat.detail/2011/09/24/1/13|14|15|16/fall-equinox-pot-luck">Fall Equinox Pot Luck</a>
</span>
</td>
</tr>
<tr>
<td class="mod_events_latest">
<span class="mod_events_latest_date">Sat Oct 01 @10:00AM</span>
-
<span class="mod_events_latest_date"></span>
<br>
<span class="mod_events_latest_content">
<a href="/coming-events/icalrepeat.detail/2011/10/01/3/13|14|15|16/yarden-prep-for-winter">Yarden Prep for Winter</a>
</span>
</td>
</tr>
</tbody>
</table>


It appears that only the rendering of the starting date is affected. (In the data, one entry has an ending time, the others do not.) The J171 upgrade was the only change made.

I have rolled back to J170 (restored old files over new) for now. Where should I look for the issue?
Duke3D
 
Posts: 4
Joined: Mon Sep 26, 2011 4:43 pm

Postby carcam » Thu Sep 29, 2011 6:48 am

that's a weird one. After the upgrade, did you check the Timezone in the first tab of the configuration area of JEvents?
¿Sabías que tenemos soporte en español para los miembros del Club de JEvents? ¡ÚNETE AHORA!
User avatar
carcam
Team Staff
 
Posts: 7114
Joined: Wed Aug 06, 2008 7:50 pm
Location: Almería

Postby Geraint » Thu Sep 29, 2011 9:26 am

also what is the custom format string for the module?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm

Postby Duke3D » Thu Sep 29, 2011 10:46 pm

Global Configuration - Server Tab - Server Timezone
= Denver

JEvents Configuration - Component tab - Timezone for site
= America/Denver

Module - Latest JEvents - Custom Format string = default
= ${eventDate}[!a: - ${endDate(%I:%M%p)}]<br />${title}

As I recall, all other settings are default other than adding a module suffix of " s3" (with leading space)and picking four categories and setting Display Mode to "3"

I now have the post upgrade site restored on a localhost XAMPP and it is unchanged - no start dates - everything else works. Very weird.
Duke3D
 
Posts: 4
Joined: Mon Sep 26, 2011 4:43 pm

Postby Geraint » Fri Sep 30, 2011 1:17 pm

try ${startDate} instead of ${eventDate}
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42850
Joined: Fri Feb 15, 2008 6:14 pm


Return to Jevents 2.x (Free Access)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there is 1 user online :: 1 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Yahoo [Bot]