JEvents 1.5 (No longer actively supported)

MINOR: Layout breaks in Chrome

JEvents 2.0 was launched over 2 years ago and the latest stable version is version 2.2 which will run on Joomla 1.5 and Joomla 2.5. JEvents 1.5 is therefore no longer actively supported - you should upgrade to JEvents 2.2+ as soon as possible.
Forum rules
Please include as much detail in any test or bug reports for JEvents 1.5 as possible.

First of all, check if you are running the latest available version of Joomla! and JEvents. Posts for issues, where both systems are not updated, will be ignored.

We need the following at least:

* PHP version (e.g. 5.2.5). Note: Support for PHP4 is discontinued.
* Joomla! version
* JEvents version
* Web Server software (Apache or IIS with version number if possible)
* Server Operating system (e.g. Linux, Windows, Solaris, Darwin ...)
* Database version
* memory_limit from your phpinfo
* Web browser and version

Please enable error reporting and include any error messages in your posting. You do this via the Joomla Configuration - set "error reporting" to "maximum" on the Server tab.

Finally, please describe the steps required to recreate the problem and also please enable error reporting and give us any error messages generated.

Postby hifi » Tue Jan 13, 2009 7:31 pm

I think this is Webkit problem, but can't be sure...

I have 8 categories, which are displayed in 2 lines in IE and FF3. In Chrome those are in one line, and whole calendar is over 100px wider than other browsers.

When I manually commented out line 77 in \components\com_jevents\views\default\month\tmpl\calendar_body.php, layout was OK.

It might be good to have some option to disable the legend, because it's not displaying full titles of categories anyway.
hifi
 
Posts: 87
Joined: Tue Oct 28, 2008 6:29 am

Postby Geraint » Tue Jan 13, 2009 10:33 pm

I think this could be a minor bug in Chrome.

The event legend blocks (div.event_legend_item) are set to float left within a fixed width container (div.event_legend_container) so then they get too wide they should flow to the next row.

If you don't want to show the legend you could add

Code: Select all
div.event_legend_container {
   display:none;
}


to your template stylesheet.

If you want to only hide the legend in the component but show it in the module use

Code: Select all
table#jevents_body div.event_legend_container {
   display:none;
}


Geraint
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42811
Joined: Fri Feb 15, 2008 6:14 pm


Return to JEvents 1.5 (No longer actively supported)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users