JEvents 1.5 (No longer actively supported)

new event is saved but not displayed

JEvents 2.0 was launched over 2 years ago and the latest stable version is version 2.2 which will run on Joomla 1.5 and Joomla 2.5. JEvents 1.5 is therefore no longer actively supported - you should upgrade to JEvents 2.2+ as soon as possible.
Forum rules
Please include as much detail in any test or bug reports for JEvents 1.5 as possible.

First of all, check if you are running the latest available version of Joomla! and JEvents. Posts for issues, where both systems are not updated, will be ignored.

We need the following at least:

* PHP version (e.g. 5.2.5). Note: Support for PHP4 is discontinued.
* Joomla! version
* JEvents version
* Web Server software (Apache or IIS with version number if possible)
* Server Operating system (e.g. Linux, Windows, Solaris, Darwin ...)
* Database version
* memory_limit from your phpinfo
* Web browser and version

Please enable error reporting and include any error messages in your posting. You do this via the Joomla Configuration - set "error reporting" to "maximum" on the Server tab.

Finally, please describe the steps required to recreate the problem and also please enable error reporting and give us any error messages generated.

Postby AlanHumphrey » Mon Jan 12, 2009 12:30 am

Added a new event and can see it in the database. however it does not appear on any calendar (latest, month, etc.)
AlanHumphrey
 
Posts: 161
Joined: Sat Dec 27, 2008 7:19 pm

Postby Geraint » Mon Jan 12, 2009 8:00 am

Did you add it in the frontend or backend?

Is it published?
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42835
Joined: Fri Feb 15, 2008 6:14 pm

Postby edigest » Mon Jan 12, 2009 9:20 pm

I have the same problem.

I created a "New iCal Event" from the backend, assigned it to a previously created category, then published it. Regardless of the date I set the event for it displays "Published, but is Coming" and does not display in the calendar (front end).

Cheers,

Ray
edigest
 
Posts: 2
Joined: Mon Jan 12, 2009 9:14 pm

Postby AlanHumphrey » Tue Jan 13, 2009 2:36 am

problem resolved by going to "manage ical subscriptions" in the backend and creating a calendar. I also had to adjust the event so it would be updated in the database. Once those two things were done the event showed up.
AlanHumphrey
 
Posts: 161
Joined: Sat Dec 27, 2008 7:19 pm

Postby edigest » Tue Jan 13, 2009 4:11 am

Thanks, Alan. That worked or me, too.

I'm curious, though. Never used JEvents or it's predecessor before. It seems needlessly complicated. Is this the way the workflow has always been?
edigest
 
Posts: 2
Joined: Mon Jan 12, 2009 9:14 pm

Postby Geraint » Tue Jan 13, 2009 9:56 am

1.5 alpha 3 is only an alpha with limited documenation.

In practice we'll probably create a native iCal ics file on installation and most users can then just igonre this feature.

The reason we have ics files and categories is to allow for calendar imports as well as native calendars.
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42835
Joined: Fri Feb 15, 2008 6:14 pm

Postby Geraint » Tue Jan 13, 2009 11:02 am

Just changed the code in SVN so that we have:
  • A single default native ICS file
  • We create such an ICS file automatically
  • We use this default ICS file for data migration

Geraint
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42835
Joined: Fri Feb 15, 2008 6:14 pm

Postby justinw1970 » Tue Jan 13, 2009 9:33 pm

On the same lines I have a test user authorised to add events as an author from the front end, but not to publish them. However when I log in as a super administrator I am unable to authorise this event. I just get a 403 error - You are not authorised to view this resource.

I set error reporting to the maximum and could see no other errors.

Although I do have a
Notice: Undefined variable: editmode in D:\xampp\htdocs\Test\templates\allediabolt\index.php on line 24 error on the calendar which I am assuming is something to do with the template with this version of jevents, which may or may not be related.

Joomla 1.5.9
PHP 5.2.8
Jevents 1.5Alpha3
justinw1970
 
Posts: 5
Joined: Mon Dec 29, 2008 6:27 pm

Postby Geraint » Tue Jan 13, 2009 10:20 pm

Can you explain exactly what you were doing when the 403 error arises - i.e. what are you clicking, in what contest, what URL etc.?

Geraint
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42835
Joined: Fri Feb 15, 2008 6:14 pm

Postby justinw1970 » Tue Jan 13, 2009 10:39 pm

Geraint wrote:Can you explain exactly what you were doing when the 403 error arises - i.e. what are you clicking, in what contest, what URL etc.?

Geraint


Sure.

I was in the backend looking at http://localhost/test/administrator/ind ... event.list

I had created an event as an author which was called test, and I was trying to publish it.

I then clicked the publish icon which came up with the error. I also got the same error when I looked at the event. Both pointed to this url: http://localhost/test/administrator/index.php

Hope that helps?
justinw1970
 
Posts: 5
Joined: Mon Dec 29, 2008 6:27 pm

Next

Return to JEvents 1.5 (No longer actively supported)

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users