Jevents 1.4 for Joomla 1.0.x

SOLVED - Cannot Add New Events in frontend

Postby TheFlyingKiwi » Fri Aug 22, 2008 11:25 am

Hi,

Firstly, thank you for this useful component and a big shout out to the developers for all their hard work.

I have a big problem in that I can no longer add events from the frontend- which is a critical feature for site i am working on. When I first installed JEvents it worked but now nothing happens when i hit the Save button. I have trawled the forum but to no avail. Here are the details:

J! v 1.0.15
PHP Version: 5.2.6
Server: Apache 2.2.9

Site Template: RT_Chromatophore
which has the initEditor settings in place

JEvents v1.4.2 then upgraded to v1.4.3 RC2 to see if that cured the issue

In FireFox V3.0.1: Nothing happens but FireBug reports the following error:
Code: Select all
document.adminForm.content is undefined
submitbutton("save")Itemid,73 (line 377)
javascript:submitbutton('save');()()javascri...('save'); (line 1)
[Break on this error] document.adminForm.intro...alue = document.adminForm.content.value;


In IE 7
line: 378
Char: 17
Error: 'document.adminForm.contnet.value' is null or not an object

Star sign: Pisces
Favourite colour: Blue
Waist: 34
Bath Night: THursday

That's about all the info I have. I am wondering if it could be a server setting or something? Magic Quotes springs to mind but I know that is set correctly.

Would be most greatful for any help
Thanks
Iain
TheFlyingKiwi
 
Posts: 4
Joined: Fri Aug 22, 2008 9:36 am

Postby TheFlyingKiwi » Fri Aug 22, 2008 12:25 pm

update:
By changing to "No default WYSUWYG Editor" i could get it to save in the front end however i have always used JCE and when i installed JEvents JCE was installed and everything worked.
TheFlyingKiwi
 
Posts: 4
Joined: Fri Aug 22, 2008 9:36 am

Postby TheFlyingKiwi » Fri Aug 22, 2008 2:43 pm

once established problem was caused by JCE - a search through the forums and i came across this post which fixed the problem
[url]
viewtopic.php?f=10&t=541&p=2117#p2117[/url]

For the JEvents team this has to be a common error - lots of folk using JCE. Perhaps it would be prudent to create a FAQ on the subject
TheFlyingKiwi
 
Posts: 4
Joined: Fri Aug 22, 2008 9:36 am

Postby Thomas » Fri Aug 22, 2008 5:18 pm

JCE works for me without problems with the default Joomla template. It might be a template issue.
Thomas
Site Admin
 
Posts: 611
Joined: Mon Feb 18, 2008 11:51 am

Postby pollux » Tue Oct 18, 2011 12:42 pm

Thanks
This is the error I get -
Fatal error: Call to undefined method ZCalendarViewCalendar::allowAdd() in /home1/freepate/public_html/bikorot/components/com_zcalendar/views/ calendar/view.html.php on line 3981
pollux
 
Posts: 1
Joined: Tue Oct 18, 2011 12:40 pm

Postby Geraint » Tue Oct 18, 2011 3:30 pm

That is zap calendar not JEvents - wrong website/support forum
JEvents Club members can get priority forum support at the Support Forum. As well as access to a variety of custom JEvents addons and benefits. Join the JEvents club today!
User avatar
Geraint
 
Posts: 42799
Joined: Fri Feb 15, 2008 6:14 pm


Return to Jevents 1.4 for Joomla 1.0.x

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there are 0 users online :: 0 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: No registered users