Jevents 1.4 for Joomla 1.0.x

No Editor in the front end

Postby erixis » Thu Jun 19, 2008 1:20 pm

I have a joomla 1.0.12 install that has JEvents installed and configured. All seems to work properly, but.... when attempting to edit or create events from the front end, there is no editor displayed. I'm using JCE as my default editor, and it shows up for editing content from the front end, and for editing events from the back end. I've checked and I have the editor enabled for the user. Anybody know how to solve this?

Eric Lewis
Posts: 3
Joined: Thu Jun 19, 2008 1:16 pm

Postby Thomas » Fri Jun 20, 2008 3:19 pm

Check if the editor is initialized in your template. Read,en_GB/
Site Admin
Posts: 611
Joined: Mon Feb 18, 2008 11:51 am

Postby erixis » Sat Jun 21, 2008 12:59 pm

This seems to be a problem with JCE and JEvents. I've got the global editor init string in my template, which is a Rocket Theme template. TinyMCE editor will display, but JCE will not. I want to use JCE because it has an image uploader icon and is overall a better editor. I'm not sure how to make this init string active for a component. The index.php does contain the following string:
global $my;
if ( $my->id ) {

If there is a way to make this 'active for a component' I'd like to know.

Upon further testing, it does seem to be a problem with JCE not being loaded properly. The Save button doesn't work with it either, but TinyMCE editor will save events.

Looks like more archive searching for me. If anybody has a reference on how to fix this, let me know!

Posts: 3
Joined: Thu Jun 19, 2008 1:16 pm

Postby erixis » Sat Jun 21, 2008 2:33 pm

Ok, I found someone who has solved this problem. It is a problem in the way JCE references the base url and how JEvents expects it to be referenced. I'll cut and paste the solution here. I found it here: ... mitstart=6

Here is the hack that I used and seems to work. This problem occurred with a Joomla! 1.0.12 installation

edit this file: /mambots/editors/jce/jscripts/tiny_mce/jce.functions.js

The - indicates the old line of code; the + indicates the line of code that should be put in place of it.

state : 'mceEditor',
toggle : '[show/hide]',
getURL : function(){
- var url = document.location.href;
+ var url = '/';
return url.substring(0, url.lastIndexOf('/'));
save : function(html){

Then edit this file:

/mambots/editors/jce/jscripts/tiny_mce/libraries/classes/jce.class.php The only change in this is to add a / to the last path called. This is in line 270 I believe.

if( $params->get('absolute_url', '0') == '1' ){
$this->tiny_url = $mainframe->getCfg('live_site') . "/mambots/editors/jce/jscripts/tiny_mce";
- $this->tiny_url = ( $mainframe->_isAdmin ) ? '../mambots/editors/jce/jscripts/tiny_mce' : '.mambots/editors/jce/jscripts/tiny_mce';
+ $this->tiny_url = ( $mainframe->_isAdmin ) ? '../mambots/editors/jce/jscripts/tiny_mce' : '/mambots/editors/jce/jscripts/tiny_mce';
return $this->tiny_url;
@@ -727,4 +727,4 @@
return $error;

This worked for me. Hope it helps if your having this problem.
Posts: 3
Joined: Thu Jun 19, 2008 1:16 pm

Postby TheFlyingKiwi » Fri Aug 22, 2008 2:39 pm

thank you very much for taking the time to post the fix to the problem. That fixed it!!!
Posts: 4
Joined: Fri Aug 22, 2008 9:36 am

Postby Ph0t0n » Sat Feb 21, 2009 12:50 pm

I have the same problem, but am running version 1.4. in J1.5 legacy mode. The above hack doesn't work cos there is no directory structure like this (I guess J1.5 is different to 1.0 in this respect).
If anyone knows how to hack J.15 to get the WYSIWYG editor working, I'd really appreciate it,
Posts: 2
Joined: Sat Feb 21, 2009 12:40 pm

Return to Jevents 1.4 for Joomla 1.0.x

  • Who is online
  • View new posts
  • View unanswered posts
  • In total there is 1 user online :: 1 registered and 0 hidden (based on users active over the past 5 minutes)
  • Most users ever online was 94 on Tue Sep 01, 2009 12:33 am
  • Users browsing this forum: Bing [Bot]